Как посчитать количество символов в строке

  Когда я захотел использовать php скрипт для Twitter-a, который постит сообщения из выбранного txt файла с набором цитат и аффоризмов, то столкнулся с необходимостью ограничить количество символов в строке до 140. Надо было посчитать и как-то удалить строки превышающие ограничение в 140 знаков.

  На помощь пришел Microsoft Excel. Решение задачи оказалось довольно простым и быстрым в исполнении.
-->    Я скопировал весь текст из блокнота в Excel, там он автоматически разбился на строчки. Для определения длины первой строчки используется формула =ДЛСТР(A1)   Если ее немного дополнить то узнаем, что удалить, а что оставить =ЕСЛИ(ДЛСТР(A1)>140;"Удалить";"Оставить")
  Там где знаков меньше 140 высветится "Оставить", там где знаков больше 140 - "Удалить".
Растягиваем эту формулу от первой до последней строки и удаляем все строчки которые нам не подходят. -->

Комментариев нет:

Отправить комментарий